
地 址:北京市平谷区66号
电 话:18960395558
网址:lcjs666.com
邮 箱:17745904@qq.com
今天大宝seo博客和朋友们分(fen)享一下网站服务器IIS日志保存(cun)查看及其参数详解,网站IIS日志是服务可以很直观的去评测网站的(de)健康与否。IIS日志存(cun)储位置:Windows2003环境中,日志IIS日志默认存(cun)储路径:C:\WINDOWS\system32\LogFiles\
在LogFiles文件夹下(xia),保存存在多个IIS日志文件夹,查看参数每(mei)个IIS日志文件夹对应一个站点日志(zhi)。详解

1、网站进入服务器的服务管理之后,打开“Internet 信息服务(wu)(IIS)管理(li)器

2、日志双击信息服务(IIS)管理器(qi),保存进入管理以后打开信息服务(IIS)管理器,查看参数选中要查看的详解网站,在(zai)网站栏目那里右键单击,网站选择“属性”:

3、服务在弹出的日志窗口里面,点击网-栏目,查看日志记录中的“属性(xing)”
4、通过日(ri)志记录属性栏目,即可(ke)看到日志文件目录了
当然IIS日志文件存储位置也可以根据自己的实际(ji)情况,在IIS管理器中重新设定。要查看(kan)对应站点的IIS日志,只(zhi)需要打开对应IIS日志文件夹找到相对应日志文件即可(ke)。也可(ke)借助IIS日志分析工(gong)具提供查看IIS日志(zhi)的效率!
IIS日志文件存储格式:IIS日志是后(hou)缀名为log的文本文件。
IIS日志(zhi)文件参数格式:
#Version: 1.0
#Date: 2017-4-26 00:00:01
#Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip
cs(User-Agent) sc-status sc-substatus sc-win32-status sc-bytes cs-bytes time-taken
2017-4-26 00:00:00 W3SVC5 116.255.197.48 GET /img/reset.css – 80 – 203.208.60.29 Mozilla/5.0+(compatible;+Googlebot/2.1;++http://www.google.com/bot.html) 200 0 0 764 245 109
2017-4-26 00:01:16 W3SVC5 116.255.197.48 GET /uploads/allimg/130218/2-13021P01541447.jpg – 80 – 125.88.189.30 Mozilla/5.0+(Windows+NT+5.1)+AppleWebKit/537.1+(KHTML,+like
IIS日(ri)志(zhi)参数详解:
date:发出请求时候的(de)日期。
time:发出(chu)请求时候(hou)的(de)时间。注意:默认情况下这个时(shi)间是格林威治时间,比我们的北京时间晚8个小时,下面有说明。
cs-username:用户名,访问(wen)服务器的已经过(guo)验证用户的名称,匿名用户用连接符-表(biao)示。
s-sitename:服务名,记录当记录事件运行于客户端上(shang)的Internet服务的名称和实例的编号。
s-ip:服务器(qi)的IP地址。
s-port:为服务配置的服务器端口号。
cs-method:请求中(zhong)使用的HTTP方法,GET/POST。
cs-uri-stem:URI资源,记录做为操作目标的统一资源标识符(URI),即访问的页面文件(jian)。
cs-uri-query:URI查询,记录客户尝试执行的查询,只有动态页面需要URI查询,如果有则记录,没(mei)有则以连接符-表示。即访问网址的附带参数。
sc-status:协议状态,记录HTTP状态代(dai)码,200表示成功,403表示(shi)没有权限,404表示找不到该页面,具体(ti)说明在下面。
sc-substatus:协议子状态,记录HTTP子状态代码。
sc-bytes:服务器发送的(de)字节数。
cs-bytes:服务器接受的字节数。
cs-version:记录客户端使用的协议版本,HTTP或(huo)者(zhe)FTP。
cs-host:记录主机头名(ming)称,没有(you)的话以(yi)连(lian)接符-表示。注意(yi):为(wei)网站配置的主机名可(ke)能(neng)会以不同的方式出现在日志文件中,原因是HTTP.sys使用Punycode编码格式(shi)来记录主机名。
cs(User-Agent):用户代理,客户端浏览器、操作系统等情况。
cs(Cookie):记录发(fa)送或(huo)者接(jie)受的Cookies内容,没有的话则以连接符-表示。
cs(Referer):引用站点,即访问来源。
HTTP协议状态码的含义,协议状态sc-status,是服务器日记扩展(zhan)属性的一项。下面是各状(zhuang)态码含义列(lie)表:
“100” : Continue 客户必须继续发出请求
“101” : witching Protocols 客户要求服务器根(gen)据请求转换HTTP协议版本 200交易成功
“200” : OK 交易成功
“201” : Created 提示知道新文件的URL
“202” : Accepted 接受和处(chu)理、但处理(li)未完成
“203” : Non-Authoritative Information 返回信息不确定或不完整
“204” : No Content 请求收到,但返回信息为空
“205” : Reset Content 服务器(qi)完成了请求,用户代理必须复位当前已经浏览过的文件
“206” : Partial Content 服务(wu)器已经完成了部分用户的GET请求
“301” : Moved Permanently 删除请求数(shu)据
“302” : Found 在其他地址发现了请求数据
“303” : See Other 建议客户访问其他URL或访问方式
“304” : Not Modified 客户端已经执行了(le)GET,但文件未变化
“305” : Use Proxy 请求的资(zi)源必须从服务器(qi)指定的(de)地址得到
“307” : Temporary Redirect 申明请求的资源临时性删除
“400” : Bad Request 错误请求,如(ru)语法错误
“401” : Unauthorized 请求授权失败
“402” : Payment required='required' 保(bao)留有效ChargeTo头响应
“403” : Forbidden 请求不答应
“404” : Not Found 没有发现文件、查询或URl
“405” : Method Not Allowed 用(yong)户在Request-Line字段定义的方法不(bu)答应
“406” : Not Acceptable 根据用户发送的Accept拖,请求资源不可访问
“407” : Proxy Authentication required='required' 类似401,用户必(bi)须首先在代理(li)服务器上(shang)得(de)到授权
“408” : Request Time-out 客户端没有在用户指定的饿时间内完成请求
“409” : Conflict 对当前资源状态,请求不能完成
“411” : Length required='required' 服务器拒绝用户定义的Content-Length属性请求
“412” : Precondition Failed 一个或(huo)多个(ge)请求头(tou)字段在当前请求中错误
“413” : Request Entity Too Large 请求的资源大于(yu)服务器答应的大小
“414” : Request-URI Too Large 请求的资源URL长于服务器答应的长度
“415” : Unsupported Media Type 请求资源不支持请求项目格式
“417” : Expectation Failed 服务器不(bu)满足请求Expect头字段指定的期望值,假如是(shi)代理服务器,
“500” : Internal Server Error 服务器产生(sheng)内部错误
“501” : Not Implemented 服务器不(bu)支(zhi)持请求的函数
“502” : Bad Gateway 服务(wu)器(qi)暂时不可用,有时是为了防止发生系统过载
“503” : Service Unavailable 服务器(qi)过载(zai)或暂停维修
“504” : Gateway Time-out 关口过载(zai),服务器(qi)使(shi)用另一个关口或服务来响应用户,等待时间设定值较长
“505” : HTTP Version not supported 服务器不支持或拒绝支请求头中指定的HTTP版本